How To Determine OBMM Version Requirements

Post Reply
User avatar
LHammonds
Site Admin
Site Admin
Posts: 712
Joined: Fri Jul 31, 2009 6:27 pm
Are you a filthy spam bot?: No
Location: Behind You
Contact:

How To Determine OBMM Version Requirements

Post: # 113Post LHammonds
Tue May 25, 2010 5:58 am

Are you creating OMODs or OMOD-Ready archives for posting on the Internet and using Oblivion Mod Manager (OBMM) scripting to help ensure a smooth installation?

You'd better make sure that the script functions you're using are actually available in the version of OBMM being used to install your mod. Not everyone uses the latest version of OBMM. ;) How do you do this? Well, you could go through Timeslips change log and try to figure out when each function became available on which version of OBMM and which version of OBMM that function became stable.

DON'T WORRY

All the research has already been done and utilized on this OBMM Script History page.

EXTRA BONUS

You don't have to drudge through your script comparing each function to the Script History research notes. You can use the OBMM Script Analyzer tool that will try its best to do that for you and recommend the minimum version of OBMM that is necessary to run your script without any problems AND it will even crank out the code for you to copy/paste at the top of your script.

OBMM Script Analyzer

NOTE: This analyzer is not perfect since all it does is search for string patterns in descending order. As soon as it finds a match, it stops and displays the version of OBMM required for the function keyword it found. The problem is that it can find the keyword "For" in a comment or in a text string. If it looks fishy, simply visit the OBMM Script History page and lookup the result yourself. The biggest problem with this tool is the "Select" keyword since it was recently modified, it is now one of the first things searched for and MANY other functions contain "Select" as part of their word. The code tries to get around it by search for "Select " with a space but it's not 100% foolproof.

Mirror Location: Wiki Nexus
Mirror Location: The Storm Raven Library

Post Reply